OpenCL works on Nvidia cards after all?

Asic transit gloria mundi.
dbz
Posts: 46
Joined: Wed Jan 11, 2012 10:16 pm
Location: the Netherlands

OpenCL works on Nvidia cards after all?

Postby dbz » Sat Jul 06, 2013 9:55 am

I noticed in the Luxmark results that Titan is able to run Luxmark. Can anybody confirm Nvidia officially supports OpenCL 1.1 after all on newer cards? (Not that someone just hacked the driver or something to get OpenCL to run).

A single GTX 680(score 4241) is faster on Luxmark than 5x GTX Titan (score 3649). Very strange ...

McAce
Posts: 7
Joined: Fri Feb 22, 2013 6:28 am

Re: OpenCL works on Nvidia cards after all?

Postby McAce » Sat Jul 06, 2013 3:54 pm

Yes, OpenCL 1.1 has been supported for a while, but the performance is usually not up to par.

Dade
Posts: 206
Joined: Fri Dec 02, 2011 8:00 am

Re: OpenCL works on Nvidia cards after all?

Postby Dade » Sun Jul 07, 2013 2:53 pm

NVIDIA has fixed OpenCL Titan drivers few weeks after the release. There was some known problem with multiple OpenCL applications (not only LuxMark) at the time of the release.

I assume they are now on par with all other NVIDIA OpenCL drivers (i.e. work well but they are slow).

dbz wrote:A single GTX 680(score 4241) is faster on Luxmark than 5x GTX Titan (score 3649). Very strange ...


LuxMark database accepts any result and it is quite easy to cheat. You have to be a bit careful while reading the results. First of all, try to use the average of all submitted results for each OpenCL device: http://www.luxrender.net/luxmark/search/avg/Sala (1418 for the 680GTX with Apple driver)

If the number of submitted result is small, even the average may be misleading so try to check all submitted results: http://www.luxrender.net/luxmark/search ... PARETOR_14

Unfortunately the number of Titan results is small so it is hard to know how reliable the information is.

dbz
Posts: 46
Joined: Wed Jan 11, 2012 10:16 pm
Location: the Netherlands

Re: OpenCL works on Nvidia cards after all?

Postby dbz » Mon Jul 08, 2013 10:57 am

McAce wrote:Yes, OpenCL 1.1 has been supported for a while, but the performance is usually not up to par.


Dade wrote:NVIDIA has fixed OpenCL Titan drivers few weeks after the release. There was some known problem with multiple OpenCL applications (not only LuxMark) at the time of the release.

I assume they are now on par with all other NVIDIA OpenCL drivers (i.e. work well but they are slow).

Ok, thanks for clarifying this. But performance is still poor anyway.

Dade wrote:LuxMark database accepts any result and it is quite easy to cheat. You have to be a bit careful while reading the results.

Ok, I only see people with NVIDIA cards cheating, btw. The results on AMD cards seem more realistic and consistent. It seems like NVIDIA customers feel like they have to compensate for something ... :D

Dade
Posts: 206
Joined: Fri Dec 02, 2011 8:00 am

Re: OpenCL works on Nvidia cards after all?

Postby Dade » Tue Jul 09, 2013 7:21 am

dbz wrote:Ok, I only see people with NVIDIA cards cheating, btw. The results on AMD cards seem more realistic and consistent. It seems like NVIDIA customers feel like they have to compensate for something ... :D


Haha but they are mostly Hackintosh (http://www.hackintosh.com) users (i.e. Apple listed as OpenCL platform instead of NVIDIA), it seems they can not refrain them self from submitting bogus results.


Return to “GPU”

Who is online

Users browsing this forum: No registered users and 3 guests